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A. Tabs - Provides access to commands and functions of Excel

B. Group — Within each tab, there are subtasks, organized by group.

C. Command Buttons — Each group contains several buttons, for carrying out commands
or displaying menus.

D. Row and Column Headings — All cells in Excel are part of a worksheet (also called a
spreadsheet). Each cell can contain data and is referred to by a lefter and number.
For example, the first cell is Al.

Named Ranges
Named Ranges can be made up of any group of cells that are given a name. Benefits
include formulas that are easier to read and simplified navigation.

¢ To name arange, first select the cells to be included.
e Use the Name Box (top left corner) to assign a name to the range OR go to Formulas 2>
Defined Names > Define Name

¢ Naming Requirements Name Box
o Must begin with a Letter, [ Selectord £
Underscore or Backslash - - -
o No spaces F)r pU.nCTUOTIOD 1 |Selector Name Department Selection Area (
o Can't conflict with cell references (A1, B12) > |yutia Acquisitions _|Fiction
o Single letters are OK except R and C 3 |sarah Youth Services Mystery

o Noft case sensitive
e For allist of all named ranges
o Click on the right side of the Name Box OR
o Go to Formulas > Defined Names > Name Manager
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Tables

Tables are more structured than Named Ranges. They are dynamic, meaning you can
easily add, remove, sort or filter the data; they can be pre-formatted; and can be
named.

e Inserting a Table: Select the cells to be included in the Table, then go to Insert > Tables
- Table, OR Home > Format as Table
¢ Naming a Table: Go to Table Tools Design > Properties - Table Name
o No spaces, no cell references, each table name must be unique
e Removing a Table: Go to Table Tools Design = Tools - Convert to Range

Structured Reference Syntax

Formulas inside a table look very different than traditional cell range formulas. These
formulas are called Structured References. Rather than referring to cell ranges or
arrays, they use column headings and table names. Generally speaking, it is easier to
use the mouse rather than typing the text strings when using Structured References,
since they tend to be longer than cell range formulas.

A B C D E F I J

Inventory

- = Bay — [Shelf Quantity — (Minimum
Name ‘L” v . v : ‘ v v v
Crayons, 16 pack 400102 D 2 8537 SO sSku 400101
Crayons, 24 pack 400103 D 3 2772 SOI JrEn pemarn .
Crayons, 8 pack 400101 D 1 197 sof
Crayons, 8 pack Wide 400104 D 4 1102 SOI
Dry erase markers, 4 pack assorted 500110 D 14 512 100|

\

Structured Reference:VLOOKUP&,lnven’rory[[#AII],[Sku]:[l\/\inimum Stock]]|3,FALSE)

Cell Range Formula=VLOOKUP(J$,B2:F41]3,FALSE)

e Table name: INVENTORY is a table name. It references the table data, without header
or total rows. Create a custom name, or leave the default (Tablel, 2, 3)

e #All: The entire table, including column headers, data, and totals (if any).
¢ Column specifier: [SKU] and [MINIMUM STOCK] use the names of the columns they

represent. They reference the column data, without header or total row. Always
enclosed in brackets.
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Additional Structured Reference Syntax
e ltem specifier: Special item specifiers that refer to specific portions of the table, such as

the total row.
e Table specifier: Represent the outer portions of the structured reference. Outer
references follow the table name, and you enclose them in square brackets.
#Data Just the data rows.
#Headers Just the header row.
#Totals  Just the total row. If none exists, then it returns null.
#This Row or @ or @[Column Name] Just the cells in the same row as the formula.

Even more syntax can be found here: https://support.microsoft.com/en-us/office/using-
structured-references-with-excel-tables-f5ed2452-2337-4f71-bed3-c8aeébéd2b27ée

Data Validation

. . . ) Select a Category|Concerts S
Limits the type of information that a cell can contain, Book Dicion 7S
such as date or time, a pre-selected list, or a limited Gt

enealogy
|engTh TO The Ce” COnTenTs. :g?::useComputuCIass <
Lectures

e Go to Data > Data Tools > Data Validation
e In Settings 2> Allow, select the type of Data Validation (e.g. Decimal, List, Time, etc.).
Follow the instructions for each category
o When creating a List, either select the correct range of data OR
o Type each category separated by a comma (e.g. Book Discussion, Civic
Discussions, Concerts, etc.)
e Click the Input Message tab to customize the Data Validation cell (e.g. “Click here to
Select Program Category”)
e Click the Error Alert tab to specify how to proceed if invalid data is entered (Stop,
Warning, Information)
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N Oy A W

~N oA WwN

gig Ei; WHEATON
) pegligP UBLIC
Advanced Microsoft Excel 2021 sdkidis LIBRARY

Lookup Functions

VLookup: stands for Vertical Lookup. Searches for a specific value in one column
and refrieves corresponding data from any column to the right of the original.

Parts of the Formula:
=vlookup (lookup_value, table_array, col_index_num, range_lookup)

=VLOOKUP(J3,B2:F7,3,FALSE)

A B C D J
Inventory
- Bay[Shelf
Name “’_“Sku |L| Locaﬁon|L| Location | ¥
Crayons, 16 pack 400102 D 2 50| | sku [I 4oo1o1|]
(Crayons, 24 pack 400103 D 3 50| shelf Location 1
Crayons, 8 pack 400101 D 1 197 50
Crayons, 8 pack Wide 400104 D 4 1102 50
Dry erase markers, 4 pack assorted 500110 D 14 512 1 Result of formula
e Lookup value: the cell reference or value text to find in the array
e Table array: the entire range of data to be included. NOTE: Lookup_value MUST be
contained in the first column of data
e Column Index Number: the column number that contains the data
e Range Lookup: Exact (false) or Approximate (tfrue) match. Defaults to Approximate
match, though Exact is usually preferred.
XLookup: Searches for a specific value in one column and retrieves corresponding
data from any other column in the array or table. NOTE: Only available in Excel 365 or
Excel 2021.
Parts of the Formula [elements in brackets are optional]
=xlookup (lookup_value, lookup_array, return_array, [if not found],
[match mode], [search mode]
=XLOOKUP(J3,B2:B7,D2:D7,"“not found”,0,1)
A B | J
Inventory
— — Bay — [Shelf ]Quantity — [Minimum
Name ‘V_" Sku ll‘ Location‘i‘ Location B Held ‘l‘ Stock ‘L‘
Crayons, 16 pack 400102 D 2 3537 50| sku [| 400101|]
|Crayons, 24 pack 400103 D S 2772 50 Shelf Location 1
Crayons, 8 pack 400101 D 1 197 50
Crayons, 8 pack Wide 400104 D 4 1102 50
Dry erase markers, 4 pack assorted 500110 D 14 512 100 Result of formula
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Lookup Value: the cell reference or value text to find in the array
Lookup Array: the array or range to search
Return Array: the array or range to return
[If not found]: text returned if no match is found (“not found”)
[Match mode]: Specifies the how the search is performed. Default is Exact (0)

o 0:exact

o l:if none found, return the next larger item

o -l:if none found, return the next smaller item

o 2:wildcard
e [Search mode]: Specifies where the match starts. Default is 1

o l:start searching at the first item

-1: start searching at the last item (reverse search)
2: binary search reliant on lookup sorted in ascending order
-2: binary search reliant on lookup sorted in descending order

o O O

Index/Match: INDEX and MATCH are two separate formulas that work well together.
To create the lookup, MATCH and INDEX are nested. MATCH returns a column
number (1,2,3, etc.), then INDEX replaces that column number with the actual value.

Parts of the Formula [elements in brackets are optional]
=index(array, row_num, [col_num], [area_num])

=match (lookup_value, lookup_array, match_type)

Combined: =INDEX(array, MATCH (lookup_value, lookup_array, match_type))

=INDEX(D2:D7,MATCH(J3,82:B7,0,))

400101“

A B

Inventory

— _I Bay [Shelf — lQuantity — |Minimum
Name |"7” Sku ’L| Location‘Ll Location |L’ Held ‘L‘ Stock ‘L]
Crayons, 16 pack 400102 D 2 3537 50| sku [|
ICrayons, 24 pack 400103 D 3 2772 50
Crayons, 8 pack 400101 D 1 197 50
Crayons, 8 pack Wide 400104 D 4 1102 50
Dry erase markers, 4 pack assorted 500110 D 14 512 100

INDEX: returns the specific value in a one-dimensional range
o Array: the array or range to search

o Row Num: selects the row in the array or range
o [Col Num]: selects the column in the array or range

Contact techclasses@wheatonlibrary.org with questions, comments, suggestions, etc.
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e MATCH: returns the position of value in the range (1, 2, 3, 4, 5). NOTE: When
using INDEX/MATCH, the result of the MATCH formula becomes the Row_Num
argument in the INDEX formula.
o Lookup Value: the cell reference or value text to find in the array
o Lookup Array: the array or range to search
o Match Type (the defaultis 1)
= -1:if none found, returns the smallest value greater than the lookup
= 0:exact match
= 1:if none found, return the largest value less than the lookup

Filter: extracts row data from a range or array, using criteria you select. NOTE: Only
available in Office365 or Office 2021.

Parts of the formula [elements in brackets are optional]
=filter(array, include, [if empty]

=FILTER(A1:D20,B1:B20=B23,"no orders")

A B C D
1/ Selector Name [Department Selection Area Quantity Ordered
2] Julia Acquisitions Fiction 174¢ A B G D
3| 'Sarah Youth Services |Mystery 25: 23 Filtered Data
4] Jonathan Access Services |SciFi 17¢ 24 |Julia ACGUISTTIONS iction 1748
5| Shreya Teen Services mance 5t 25 Yuki Acquisitions Automobiles 167
6] Meer Youth Services |Gardening 45; 26 |Mavis Acquisitions History 359
7] Rosa Access Services |Dinosaurs 30: 27 |Ibrahim Acquisitions Pets 167
8] Yuki Acquisitions Automobiles 167
9] Paul Access Services |Royalty 20¢
1q |Margot Youth Services |Travel 40¢
11 Emmy Access Services |Finance 17t
1] Oscar Access Services |Cooking 63¢
13 Q‘::mon Teen Services  |Parenting ID
14 o baen Mmssbla € omviiimm 1o 10¢

Array: the table or group of columns and rows

Include: equation to look for the filtered results (B1:B20=b23; b1:020= “Youth Services”)
[if empty]: specialized messages for when no results are available

Make sure you have enough empty cells for all the filtered data. Otherwise, you may
get a #SPILL error.

Contact techclasses@wheatonlibrary.org with questions, comments, suggestions, etc. 6
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Which Lookup Function Should You Use@

VLookup XLookup Index/Match

Return array must be fo the right Return array can be fo Return array can be to the left or right
of the Lookup array the left or right

Return array is expressed as the Highlight the return Return array is expressed as a
number of columns to the right of  column combination of the number of

the lookup columns/rows and the lookup value
For approximate values, lookup Lookup array does not Lookup array does not need to be
array must be in ascending order  need to be sorted sorted

Cannot do a horizontal lookup Works horizontally or Works horizontally or vertically

(use HLookup instead) vertically

Defaults to approximate match Defaults to exact match  Defaults to approximate match

Available in all versions of Excel Only available in 365 or Available in all versions of Excel
2021

Data Visualization

Craft Programs had peak attendance in
February 2022

Chart Title

A

Jan-22  Feb-22 Mar-22  Apr-22 May-22 Jun-22  Jul22  Aug-22 Sep-22 Oct-22 Nov-22 Dec-22

e Use Page Layout > Themes 2> Colors to add brand colors or create your own scheme

e Declutter the chart area by removing unnecessary elements (axis lines, chart border,
etc.). Right-click on Chart > Format Chart Area

e Increase font size of axes and Data Table to increase readability.

e Replace Chart Title with brief description of the “story” you want to tell.
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Excel Keyboard Shortcuts

Select the entire worksheet Ctrl + A
Select all non-blank cells on the right Ctrl + Shift+ >-
Select all non-blank cells on the left Ctrl + Shift + &

Select the column from the current cell to the last non-blank  Ctrl + Shift + -
cell in the same column

Select all the cells above the selected cell Ctrl + Shift + A
Select the column from the current cell to the last non-blank

cellin the table

Select the entire row Shift + Space

Select the entire column Ctrl + Space

Select from the Current Cell to the last cell with data Ctrl + Shift + End

Select the Adjacent Cell Shift + > &V

Go to the First Cell of your worksheet Ctrl + Home

Go to the Last Cell of your worksheet Ctrl + End

Move to the next worksheet Ctrl + Page Up/Page
Down

Start a new line in a formula Ctrl + Enter

Toggle between displaying cell values and formulas Ctrl + ° (single quote, top
left of keyboard)

Repeat the last action performed in the formula bar F4

Cut Ctrl + X

Copy Ctrl+ C

Paste Ctrl+V

Copy the contents and format of the first cell in a select Ctrl+ D

range into the cells below

Copy formula from cell above Ctrl + * (Apostrophe, to the
left of the Enter key)

Paste Special Ctrl + Shift + V

Repeat/Redo the last action Cirl+Y

Enter the current date Ctrl +;

Enter the current time Ctrl + Shift + ;

Insert Function Shift + F3

Flash Fill Ctrl+E
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